Ticket #1440 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Incorrect editor behavior when <No translation> is selected in "Choose codepage" menu

Reported by: ache Owned by: angel_il
Priority: major Milestone: 4.7.0-pre2
Component: mcedit Version: 4.7.0-pre1
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

When in editor I select <No translation> in "Choose codepage" menu, leave editor, then open a file, all symbols are displayed as dots, all symbols I enter become 0x2E. If I open "Choose codepage" and select any codepage (even <No translation> again), everything comes back to normal.

I think that in <No translation> mode viewer and editor should assume the text is in the default system locale.

Gentoo Linux, AMD64, ebuild from GIT, commit: d3f1b16bcf17f5748d6faa2d3ca157de22d910ae

System locale: ru_RU.UTF-8. In "Display bits" "Input / display codepage" is set to UTF-8, "Full 8 bits input" is on.

Change History

comment:1 Changed 10 years ago by zaytsev

  • Version changed from 4.7.0-pre1 to master
  • Milestone changed from 4.7 to 4.7.0-pre2

Confirmed on master / EL5 x86 / en_US.UTF-8.

comment:2 Changed 10 years ago by angel_il

  • Version changed from master to 4.7.0-pre1

comment:3 Changed 10 years ago by zaytsev

Why did you change the version? It's reproduceable on master (which should take precedence over more dated codebase).

comment:4 Changed 10 years ago by angel_il

  • Owner set to angel_il
  • Status changed from new to accepted

comment:5 Changed 10 years ago by angel_il

  • Status changed from accepted to testing
  • Resolution set to fixed

fix in #1529

comment:6 Changed 10 years ago by angel_il

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.