Ticket #1428 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

autogen.sh libtool Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac

Reported by: gzp Owned by: slavazanko
Priority: blocker Milestone: 4.7.0-pre1
Component: mc-core Version: master
Keywords: libtool autoconf Cc:
Blocked By: Blocking:
Branch state: Votes for changeset: committed-master

Description

Running autogen.sh in current git at 20090728 results in:

libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac and
libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree.
configure:1758: error: possibly undefined macro: _m4_text_wrap_word

If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.

$ libtool --version
ltmain.sh (GNU libtool) 2.2.6
$ autoconf --version
autoconf (GNU Autoconf) 2.64
$ automake --version
automake (GNU automake) 1.11

Attachments

log.autogen (3.4 KB) - added by gzp 10 years ago.
Output of autogen.sh
configure (791.3 KB) - added by gzp 10 years ago.
Created wrong configure script

Change History

Changed 10 years ago by gzp

Output of autogen.sh

Changed 10 years ago by gzp

Created wrong configure script

comment:1 Changed 10 years ago by iNode

  • Priority changed from major to blocker
  • Version changed from 4.6.2 to master
  • Milestone changed from 4.7 to 4.7.0-pre1

comment:2 Changed 10 years ago by iNode

I can't reproduce it:

$ libtool --version
ltmain.sh (GNU libtool) 2.2.6
$ autoconf --version
autoconf (GNU Autoconf) 2.63
$ automake --version
automake (GNU automake) 1.10.2

It seems to be some autotools incompatibility/strictness.

What last version of mc build correctly in your environment?

comment:3 Changed 10 years ago by angel_il

gzp:
try apply autoconf.2.patch and run ./autogen.sh
after this
show result
./configure --help

comment:4 Changed 10 years ago by angel_il

  • Milestone changed from 4.7.0-pre1 to 4.7.0-pre2

comment:5 Changed 10 years ago by slavazanko

  • Owner set to slavazanko
  • Status changed from new to accepted
  • Milestone changed from 4.7.0-pre2 to 4.7.0-pre1

Created branch 1428_AC_CONFIG_MACRO_DIR (parent: master)

initial changeset:5183c815606778213ccc61c66660ac40aa93c5df

Review, please.

comment:6 Changed 10 years ago by slavazanko

  • severity changed from no branch to on review

comment:7 Changed 10 years ago by angel_il

  • Votes for changeset set to angel_il

comment:8 Changed 10 years ago by andrew_b

  • Keywords autoconf added

Changeset work correctly with autoconf=2.61.

But I noticed that ./configure --help message contains the following lines:

  --disable-vfs-cpio    Support for cpio filesystem [yes]
  --disable-vfs-tar     Support for tar filesystem [yes]
  --disable-vfs-ftp     Support for FTP vfs [yes]
  --disable-vfs-fish           Support for FISH vfs [yes]
  --disable-vfs-extfs       Support for extfs [yes]
  --disable-vfs-sfs         Support for sfs [yes]

I think something is not correct here. ;)

comment:9 follow-up: ↓ 10 Changed 10 years ago by iNode

  • Votes for changeset angel_il deleted

Add two small changeset too:
first - for option names
and second - for indent of description

please review

comment:10 in reply to: ↑ 9 Changed 10 years ago by iNode

I mean second

Thanks.

comment:11 follow-up: ↓ 12 Changed 10 years ago by andrew_b

  • Votes for changeset set to andrew_b

Looks OK.

comment:12 in reply to: ↑ 11 ; follow-up: ↓ 13 Changed 10 years ago by iNode

Replying to andrew_b:

Looks OK.

Third also indent fix but in global configure.ac

comment:13 in reply to: ↑ 12 Changed 10 years ago by iNode

Replying to iNode:

Replying to andrew_b:

Looks OK.

Third also indent fix but in global configure.ac

yet another patch it fix option name from --search-engine to --with-search-engine

comment:14 Changed 10 years ago by angel_il

  • Votes for changeset changed from andrew_b to andrew_b angel_il
  • severity changed from on review to approved

comment:15 Changed 10 years ago by angel_il

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b angel_il to commited-master
  • Resolution set to fixed
  • severity changed from approved to merged

comment:16 Changed 10 years ago by angel_il

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.