Ticket #1405 (closed defect: invalid)

Opened 10 years ago

Last modified 9 years ago

fish should honor .ssh/config settings

Reported by: jhrozek Owned by:
Priority: minor Milestone: 4.7
Component: mc-vfs Version: 4.6.2
Keywords: Cc: roti,
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

Fish support (left/Right->Shell link) does not honor .ssh/config setting, but IMHO it should this is esp. annoying with usernames or ports set for different systems. Consider:

Host testmachine.evilempire.com
    User                    tester
    Port                    2222
    StrictHostKeyChecking   no

Putting just the hostname into the shell link dialog should connect you to tester@testmachine.evilempire.com:2222

Change History

comment:1 Changed 10 years ago by iNode

  • Component changed from mc-core to mc-vfs
  • Type changed from defect to enhancement

Thanks for request. Cause it no bug we will get it a bit later.
For now you can use hotlist for fast navigation.

comment:2 follow-up: ↓ 6 Changed 9 years ago by roti

  • Type changed from enhancement to defect

I can connect using an alias from .ssh/config, but when I try to delete a file, it does not get deleted.

comment:3 Changed 9 years ago by slavazanko

Unable to reproduce. I can connect to any host by simple hostname (but with some additional parameters onto ~/.ssh/config like Port or User).

Also, all file operations (copy/move/delete) works fine.

$ lsb_release -a
LSB Version:    :core-3.1-ia32:core-3.1-noarch:graphics-3.1-ia32:graphics-3.1-noarch
Distributor ID: CentOS
Description:    CentOS release 5.4 (Final)
Release:        5.4
Codename:       Final

Please, show some additional info about your client mashine.

comment:4 Changed 9 years ago by slavazanko

for additional check, run 'ssh' command:

ssh <some.host>

where <some.host> must be present into your ~/.ssh/config file

Mc use 'ssh' for shell-link. Actually, mc it's a wrapper around ssh.

For check 'remove file' action just run:

ssh <some.host> '/bin/rm -f /path/to/file.ext'

comment:5 Changed 9 years ago by slavazanko

  • Cc roti added

comment:6 in reply to: ↑ 2 Changed 9 years ago by andrew_b

Replying to roti:

I can connect using an alias from .ssh/config, but when I try to delete a file, it does not get deleted.

What version of MC are you using?

comment:7 Changed 9 years ago by roti

2:4.6.2-2ubuntu1

comment:8 Changed 9 years ago by slavazanko

  • Status changed from new to closed
  • Resolution set to invalid

4.6.2-2ubuntu1

ops... sorry, but this version now unsupported. Touch maintainers of your distro for update mc to latest version (latest stable is 4.7.0.2)

Note: See TracTickets for help on using tickets.