Ticket #4358: checki.diff

File checki.diff, 1.3 KB (added by ats, 5 months ago)

Patch: rename _i/_j to ii/jj

  • mc-4.8.28/tests/lib/strutil/filevercmp.c

    START_TEST uses the variable name _i, so GCC complains about redefining it with
    a different type here.
    
     
    353353START_TEST (filevercmp_test5) 
    354354/* *INDENT-ON* */ 
    355355{ 
    356     size_t _i; 
     356    size_t ii; 
    357357 
    358     for (_i = 0; _i < filevercmp_test_ds5_len; _i++) 
    359         for (; filevercmp_test_ds5[_i] != NULL; _i++) 
     358    for (ii = 0; ii < filevercmp_test_ds5_len; ii++) 
     359        for (; filevercmp_test_ds5[ii] != NULL; ii++) 
    360360        { 
    361             const char *i = filevercmp_test_ds5[_i]; 
    362             size_t _j; 
     361            const char *i = filevercmp_test_ds5[ii]; 
     362            size_t jj; 
    363363 
    364             for (_j = _i; filevercmp_test_ds5[_j] != NULL; _j++) 
     364            for (jj = ii; filevercmp_test_ds5[jj] != NULL; jj++) 
    365365            { 
    366                 const char *j = filevercmp_test_ds5[_j]; 
     366                const char *j = filevercmp_test_ds5[jj]; 
    367367 
    368                 ck_assert_int_eq (test_filevercmp (i, j), 0); 
    369                 ck_assert_int_eq (test_filevercmp (j, i), 0); 
     368                ck_assert_int_eq (test_filevercmp (i, j), 0); 
     369                ck_assert_int_eq (test_filevercmp (j, i), 0); 
    370370            } 
    371371        } 
    372372}