1 | # Copyright 1999-2009 Gentoo Foundation |
---|
2 | # Distributed under the terms of the GNU General Public License v2 |
---|
3 | # $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.7.0_pre3.ebuild,v 1.7 2009/11/26 18:34:35 armin76 Exp $ |
---|
4 | |
---|
5 | EAPI=2 |
---|
6 | inherit eutils |
---|
7 | MY_P=${P/_/-} |
---|
8 | |
---|
9 | DESCRIPTION="GNU Midnight Commander is a text based file manager" |
---|
10 | HOMEPAGE="http://www.midnight-commander.org" |
---|
11 | SRC_URI="http://www.midnight-commander.org/downloads/${MY_P}.tar.bz2" |
---|
12 | |
---|
13 | LICENSE="GPL-2" |
---|
14 | SLOT="0" |
---|
15 | KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ~ppc64 s390 sh sparc x86 ~x86-fbsd" |
---|
16 | IUSE="+edit gpm nls samba slang X" |
---|
17 | |
---|
18 | RDEPEND=">=dev-libs/glib-2.14:2 |
---|
19 | gpm? ( sys-libs/gpm ) |
---|
20 | kernel_linux? ( sys-fs/e2fsprogs ) |
---|
21 | samba? ( net-fs/samba ) |
---|
22 | slang? ( >=sys-libs/slang-2 ) |
---|
23 | !slang? ( sys-libs/ncurses ) |
---|
24 | X? ( x11-libs/libX11 |
---|
25 | x11-libs/libICE |
---|
26 | x11-libs/libXau |
---|
27 | x11-libs/libXdmcp |
---|
28 | x11-libs/libSM )" |
---|
29 | DEPEND="${RDEPEND} |
---|
30 | dev-util/pkgconfig |
---|
31 | nls? ( sys-devel/gettext )" |
---|
32 | |
---|
33 | S=${WORKDIR}/${MY_P} |
---|
34 | |
---|
35 | src_prepare() { |
---|
36 | rm -f m4/{libtool,lt*}.m4 || die "libtool fix failed" |
---|
37 | epatch "${FILESDIR}"/${P}-copy-queue.patch |
---|
38 | AT_NO_RECURSIVE="yes" eautoreconf |
---|
39 | } |
---|
40 | |
---|
41 | src_configure() { |
---|
42 | local myscreen=ncurses |
---|
43 | use slang && myscreen=slang |
---|
44 | |
---|
45 | econf \ |
---|
46 | --disable-dependency-tracking \ |
---|
47 | $(use_enable nls) \ |
---|
48 | --enable-vfs \ |
---|
49 | $(use_enable kernel_linux vfs-undelfs) \ |
---|
50 | --enable-charset \ |
---|
51 | $(use_with X x) \ |
---|
52 | $(use_with samba) \ |
---|
53 | --with-configdir=/etc/samba \ |
---|
54 | --with-codepagedir=/var/lib/samba/codepages \ |
---|
55 | $(use_with gpm gpm-mouse) \ |
---|
56 | --with-screen=${myscreen} \ |
---|
57 | $(use_with edit) |
---|
58 | } |
---|
59 | |
---|
60 | src_install() { |
---|
61 | emake DESTDIR="${D}" install || die |
---|
62 | dodoc AUTHORS README |
---|
63 | } |
---|
64 | |
---|
65 | pkg_postinst() { |
---|
66 | elog "To enable exiting to latest working directory," |
---|
67 | elog "put this into your ~/.bashrc:" |
---|
68 | elog ". /usr/libexec/mc/mc.sh" |
---|
69 | elog "" |
---|
70 | elog "Dany: This version handles single background" |
---|
71 | elog "jobs running." |
---|
72 | elog "For info: <danilo.schembri@gmail.com>" |
---|
73 | } |
---|