Ticket #83 (assigned enhancement)

Opened 11 years ago

Last modified 4 years ago

savannah: editor needs read-only mode

Reported by: ossi Owned by:
Priority: major Milestone: Future Releases
Component: mcedit Version: 4.7.1
Keywords: Cc: dev.nul@…, mooffie@…
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description (last modified by ossi) (diff)

Original: http://savannah.gnu.org/bugs/?23513

Submitted by:Oswald Buddenhagen <ossi>Submitted on:Sat 07 Jun 2008 07:57:22 AM UTC
Category:EditorSeverity:3 - Normal
Status:NonePrivacy:Public
Assigned to:NoneOpen/Closed:Open
Release:current (CVS or snapshot)Operating System:All

Original submission:

the editor needs a read-only mode. in this mode, cursor navigation 
would work as normal, but any attempt to modify the content would 
pop up a confirmation dialog requesting to switch the mode.
the mode would be initialized from the file's access rights. a 
manual toggle (and possibly a command line switch to be able to use 
the editor as a viewer) would be provided. 

Attachments

dirty_readonly.diff (2.1 KB) - added by angel_il 10 years ago.
first iteration
mc.patch (7.2 KB) - added by nickk9 9 years ago.
mc1.patch (13.0 KB) - added by nickk9 9 years ago.

Change History

comment:1 Changed 11 years ago by slavazanko

  • Component changed from mc-core to mcedit

comment:2 Changed 11 years ago by metux

  • Type changed from defect to enhancement

comment:3 Changed 10 years ago by angel_il

  • Status changed from new to accepted
  • Owner set to angel_il

comment:4 Changed 10 years ago by kdave

  • Version set to 4.6.1
  • Summary changed from savannah: need read-only mode to savannah: editor needs read-only mode
  • Milestone set to 4.7

Changed 10 years ago by angel_il

first iteration

comment:5 Changed 10 years ago by styx

#28 should be improved, not this one. At least this feature looks strange enough. And in the lights of previous days I think we just should merge viewer. For now viewer has hex editor ...

comment:6 Changed 10 years ago by styx

  • Status changed from accepted to testing
  • Resolution set to invalid

comment:7 Changed 10 years ago by styx

  • Status changed from testing to closed

comment:8 follow-up: ↓ 11 Changed 9 years ago by nickk9

  • Status changed from closed to reopened
  • severity set to no branch
  • Cc dev.nul@… added
  • Component changed from mcedit to mcview
  • Version changed from 4.6.1 to 4.7.1
  • Resolution invalid deleted

There is another convenient solution for this issue. It would be great if viewer would have key shortcut to run editor on the same file (so i view some file, understand that i need to edit it, then press, say Alt-F4 and get editor on this file from the same position).

Changed 9 years ago by nickk9

comment:9 Changed 9 years ago by nickk9

  • Status changed from reopened to accepted
  • Owner changed from angel_il to nickk9

Here is proposed patch to implement this (default key binding is F14 aka shift-F4, keymap name ViewRunEditor?).

Changed 9 years ago by nickk9

comment:10 Changed 9 years ago by nickk9

I thought that default editor behaviour (placing current line in the middle of the window) not convenient when switching from viewer to editor (thus is results in shifting text), so i modified abovementioned patch to disable such scrolling in this very case.

comment:11 in reply to: ↑ 8 Changed 9 years ago by andrew_b

It's not a solution for "read-only mode of editor". Ticket #2156 was created for "run editor from viewer" enhancement.

comment:12 Changed 9 years ago by andrew_b

  • Component changed from mcview to mcedit

comment:13 Changed 8 years ago by andrew_b

  • Branch state set to no branch
  • Milestone changed from 4.7 to Future Releases

comment:14 Changed 7 years ago by andrew_b

  • Status changed from accepted to assigned
  • Owner nickk9 deleted

comment:15 Changed 6 years ago by ossi

  • Description modified (diff)
  • Reporter changed from slavazanko to ossi

comment:16 Changed 5 years ago by andrew_b

Ticket #3211 has been marked as a duplicate of this ticket.

comment:17 Changed 4 years ago by mooffie

  • Cc mooffie@… added
Note: See TracTickets for help on using tickets.