Ticket #4476 (closed enhancement: duplicate)

Opened 9 months ago

Last modified 8 months ago

option to copy files in the background

Reported by: geekabit Owned by:
Priority: major Milestone:
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Copying big files can take a while. Instead of staring at the progress bar until the action is complete, I would like to be able to do other things in midnight commander.
The enhancement I suggest is to add an extra button to the file copy screen with the progress bar, next to the skip, suspend and abort buttons. Let's call it the background button. A push of the background button would move the copy process to the background, freeing up the user interface to do other things. This is a feature I've seen in Total Commander (a Windows clone of NC) and used a lot.

Change History

comment:1 Changed 9 months ago by zaytsev

Don't we already have a background jobs function o_O ? Related: #2240 .

comment:2 Changed 9 months ago by geekabit

You are right. How did I miss this? Thanks Zaytsev.

The ticket can be closed.

comment:3 Changed 8 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #2240.

Note: See TracTickets for help on using tickets.