Ticket #4411 (closed enhancement: duplicate)

Opened 15 months ago

Last modified 15 months ago

7z password protected archives

Reported by: maxz Owned by:
Priority: major Milestone:
Component: mc-vfs Version: master
Keywords: 7z Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

When you try to view encrypted file in 7z archive, MC hangs up.
Only kill MC process helps.
The solution is simple:

diff --git a/src/vfs/extfs/helpers/u7z b/src/vfs/extfs/helpers/u7z
index 91301c3d9..603c976d3 100755
--- a/src/vfs/extfs/helpers/u7z
+++ b/src/vfs/extfs/helpers/u7z
@@ -74,7 +74,7 @@ mcu7zip_copyout ()
         #first we check if we have old p7zip archive with prefix ./ in filename
         $P7ZIP l "$1" "$2" | grep -q "0 files, 0 folders" && \
         EXFNAME='*./'"$2" || EXFNAME="$2"
-        $P7ZIP e -so "$1" "$EXFNAME" > "$3" 2>/dev/null
+        $P7ZIP e -so -p- "$1" "$EXFNAME" > "$3" 2>/dev/null
 }
 
 mcu7zip_copyin ()


The same problem with rar and zip encrypted archives but patch exists on the net, but still is not included in MC sources.

Attachments

compressed_encryption_fix.patch (1.8 KB) - added by maxz 15 months ago.
existing patch with 7z addition

Change History

Changed 15 months ago by maxz

existing patch with 7z addition

comment:1 Changed 15 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #1685.

Note: See TracTickets for help on using tickets.