Ticket #4393 (closed defect: invalid)

Opened 21 months ago

Last modified 20 months ago

mc doesn't open images, pdfs and other document types anymore

Reported by: cimbi Owned by:
Priority: major Milestone:
Component: mc-core Version: 4.8.28
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

When trying to open file types like .jpg, .png, .pdf and some others via the Enter key or mouse double click nothing happens anymore. No external program gets started.

It seems that all file types in mc.ext which are using the type keyword are affected.

Problem is most probably related to the latest version of the file(1) utility. With file-5.41 opening of files works fine, with file-5.42 it doesn't work anymore.

Change History

comment:1 Changed 21 months ago by cimbi

  • Version changed from master to 4.8.28

comment:2 Changed 21 months ago by andrew_b

Probably related to #4377.

comment:3 Changed 21 months ago by andrew_b

Sorry, I cannot reproduce this. mc with file-5.42 works fine for me.

comment:4 follow-up: ↓ 5 Changed 20 months ago by cimbi

After further investigation I found out that it happens only when there are some national characters (like ěščřžýáíé) in the file path.

It is a bug in latest version of the file utility (5.42) negatively impacting mc behavior. I have opened a ticket for this issue in the file project.

comment:5 in reply to: ↑ 4 Changed 20 months ago by andrew_b

Replying to cimbi:

I have opened a ticket for this issue in the file project.

There are two tickets were created before:
https://bugs.astron.com/view.php?id=362
https://bugs.astron.com/view.php?id=363

comment:6 Changed 20 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to invalid
  • Milestone Future Releases deleted

Already fixed in #4377.

Note: See TracTickets for help on using tickets.