Ticket #4370 (closed defect: fixed)

Opened 23 months ago

Last modified 13 months ago

wrong return from panelize if panelized in both panels

Reported by: newbie-02 Owned by: andrew_b
Priority: major Milestone: 4.8.30
Component: mc-core Version: master
Keywords: panelize directory Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description (last modified by andrew_b) (diff)

perform a search in one panel, panelize the search,
starting from another directory do the same in the other panel,
switch back to the first panel, if you leave the view by the '..'
at the top of the list you come back to the directory where you
started the second search.

What version of Midnight Commander is used?

Put output of mc -V command (and all other commands described in 'How to report about bugs') here.

GNU Midnight Commander 4.8.27
Built with GLib 2.68.4
Built with S-Lang 2.3.2 with terminfo database
With builtin Editor and Aspell support
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
With ext2fs attributes support
Virtual File Systems:
 cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, sftpfs, fish
Data types:
 char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

What steps will reproduce the problem?

see above description,

What is the expected output?

switch back to the directory where the search for that panel was started,

What do you see instead?

switch to the directory where the other search was started.

Change History

comment:1 Changed 22 months ago by andrew_b

  • Description modified (diff)

Currently by design MC saves only one panelization result. Second panelization clears result of first one.

Yes, I agree than each file panel should have own buffer for panelization.

comment:2 Changed 13 months ago by andrew_b

  • Owner set to andrew_b
  • Status changed from new to accepted
  • Branch state changed from no branch to on review
  • Milestone changed from Future Releases to 4.8.30

comment:3 Changed 13 months ago by andrew_b

  • Votes for changeset set to andrew_b
  • Branch state changed from on review to approved

comment:4 Changed 13 months ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:5 Changed 13 months ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.