Ticket #4274 (closed defect: duplicate)

Opened 3 months ago

Last modified 3 months ago

mc uses dhotfocus color for selected entry in the history dialog

Reported by: mstilkerich Owned by:
Priority: major Milestone:
Component: mc-skin Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Hello,

I am in the process of creating a color scheme based on the solarized colors palette using truecolors.

I noticed that mc uses the dialog.dhotfocus color for the selected entry in the history list. My understanding of this color is it should be used for single hotkey characters, and therefore use for the entire entry in the history list comes unexpected to me.

What I would expect here is the use of dialog.dfocus instead. After all, the non-selected entry also uses the dialog._default_ color, not dialog.dhotnormal which would be the non-focused pendant to dhotfocus.

A screenshot is available here https://github.com/mstilkerich/mc-solarized-truecolor/blob/553183d61c17f310ffb2d0b7beb5a7392f18bc3e/screenshots/dark-truecolor-history-dialog.png.

The corresponding skin file is this:
https://github.com/mstilkerich/mc-solarized-truecolor/blob/553183d61c17f310ffb2d0b7beb5a7392f18bc3e/solarized-dark-truecolor.ini

Is this intended? It doesn't look nicely as normally this color style is only used for single characters.

Change History

comment:1 Changed 3 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Version changed from 4.8.27 to master
  • Component changed from mc-core to mc-skin
  • Milestone Future Releases deleted

Closed as duplicate of #3160.

Note: See TracTickets for help on using tickets.