Ticket #4199 (closed enhancement: duplicate)

Opened 10 months ago

Last modified 10 months ago

Check for FAT file size limit when copying (large) files

Reported by: iromeister Owned by:
Priority: minor Milestone:
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

When I copy a file > 4GB to a FAT partition, e.g. on a (slow) flash drive, mc happily starts copying the file until it hits the 4 GB boundary of the FAT file system. Only then it tells me that I can't copy that file because it's too large.

It would be nice to have mc checking that file size limit before starting to copy.

In theory this applies to other file size limits as well, but in practice I only experienced this as a problem with FAT. Maybe it would be wise to implement it a bit more general though.

Change History

comment:1 Changed 10 months ago by ossi

one would have to jump through hoops to make it not general. ;)

the code for finding free space is already there, but it's used only for the panels.

note that free space reporting is not reliable on highly complex modern file systems (and concurrent activity can change the situation any time anyway), so low space should be only a warning rather than aborting immediately.

comment:2 Changed 10 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #2351.

Note: See TracTickets for help on using tickets.