Ticket #4106 (closed defect: invalid)

Opened 2 years ago

Last modified 2 years ago

Regression in mc 4.8.25: Switching panels with L/R cursor keys doesn't work anymore

Reported by: Axanar Owned by:
Priority: major Milestone:
Component: mc-core Version: 4.8.25
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

The new update of Midnight Commander has a panel navigation regression.

The older versions of Midnight Commander had the capabilities to navigate with the cursor left and right keys within the panels. E.g. pressing cursor right moved to the right panel (including selection of the last selection). E.g. pressing cursor left moved to the left panel (including selection of the last selection).

With this update the panel switch is limited to pressing <TAB> only. There is no possibility to swith the panels using the cursor keys anymore as it used to be the case for years.

Reading the changelogs on midnight-commander.org doesn't show any signs of changes in that regard. So there might be a regression during "code" cleanup.

Please note that I also reported this bug to fedora, since I use their prebuild made RPM file.

https://bugzilla.redhat.com/show_bug.cgi?id=1858574

I will also add my mc ini file, so comparison can be made with previous and current version of mc.

Attachments

ini (3.4 KB) - added by Axanar 2 years ago.
The matching ini file to test the regression

Change History

Changed 2 years ago by Axanar

The matching ini file to test the regression

comment:1 in reply to: ↑ description Changed 2 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to invalid
  • Milestone Future Releases deleted

Replying to Axanar:

The new update of Midnight Commander has a panel navigation regression.

No.

The older versions of Midnight Commander had the capabilities to navigate with the cursor left and right keys within the panels. E.g. pressing cursor right moved to the right panel (including selection of the last selection). E.g. pressing cursor left moved to the left panel (including selection of the last selection).

Vanilla MC never had such behaviour out of box.

With this update the panel switch is limited to pressing <TAB> only.

This is normal behaviour.

There is no possibility to swith the panels using the cursor keys anymore as it used to be the case for years.

No again.

Reading the changelogs on midnight-commander.org doesn't show any signs of changes in that regard. So there might be a regression during "code" cleanup.

No.

comment:2 Changed 2 years ago by Axanar

Hello and thanks for the comprehensive answer.

From what I know:

a) Lynx type movement, you dive into subdirs and or get out of them (never used that)
b) With some types of parameters you have to use <TAB> to switch the panels

... but ...

With the example ini file that I provided (which was generated a long time ago (years)). You are indeed able (if you turn off menu, function keys, command line, etc. (through the settings within mc)) you are indeed able to use the cursor keys LEFT and RIGHT to switch the panel.

... and ...

I just downloaded mc 4.8.24 sources from your very own ftp server and compiled it from scratch by issuing:

./configure --prefix=/usr --sysconfdir=/etc

and compiled it (with S-LANG) backend. I also made sure that all existing mc installations based on fedoras rpm got removed. I installed the compiled mc and was able to navigate (with the provided ini file) using the LEFT and RIGHT cursor arrow keys.

May I ask if you could at least verify my valid bugreport before closing it ? I ask, because I can confirm that vanilla MC had such a behaviour out of the box for years. Even back when de icaza initially coded it (that far back). Using the provided "ini" file makes sure that the setup matches the one I have here at home.

Thank you for your time and support.

comment:3 Changed 2 years ago by andrew_b

Indeed, it worked. But in some exotic configuration: only panels are visible, others (menubar, keybar, command prompt, hintbar) are hidden, both panels in single column mode. If other panel is in quick view mode, you can move to it but cannot return from. Even if other panel is in file listing mode, but have more than one column, you cannot move form multi-column to single-column panel too.

In general, it looks like am unexpected and partially working behaviour. I can't say how many people use such layout. Very little, I suspect. As I can see around me, most don't change the default layout.

Apparently, won't fix.

Note: See TracTickets for help on using tickets.