Ticket #4089 (closed defect: duplicate)

Opened 4 years ago

Last modified 22 months ago

can't change directory after ftp timeout

Reported by: jarek Owned by:
Priority: minor Milestone:
Component: mc-vfs Version: 4.8.24
Keywords: timeout Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description (last modified by andrew_b) (diff)

LC_MESSAGES=C mc -V
GNU Midnight Commander 4.8.24-137-ge132d7177
Built with GLib 2.46.2
Built with S-Lang 2.3.0 with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With internationalization support
With multiple codepages support
With ext2fs attributes support
Virtual File Systems:
 cpiofs, tarfs, sfs, extfs, ftpfs, sftpfs, fish
Data types:
 char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

OS: Slackware 14.2 x64

I'm using polish version, so some text may be different.

  1. Connect to FTP via right->connect ftp->user->password
  2. Do something else for some time.
  3. Try to go somewhere else in FTP tree

I get "can't change directory"
and I suppose to just change directory or to be able to copy files.

If I try recconect (1) I got error. When I try to close "active VFS" via command, nothing happens, FTP remains displayed there.

Only one helps - quit mc and start it again and do (1)

jarek@trasownik:~/blachy$ LC_MESSAGES=C mc -F
Home directory: /home/jarek
Profile root directory: /home/jarek

[System data]
    Config directory: /usr/local/etc/mc/
    Data directory:   /usr/local/share/mc/
    File extension handlers: /usr/local/libexec/mc/ext.d/
    VFS plugins and scripts: /usr/local/libexec/mc/
	extfs.d:        /usr/local/libexec/mc/extfs.d/
	fish:           /usr/local/libexec/mc/fish/

[User data]
    Config directory: /home/jarek/.config/mc/
    Data directory:   /home/jarek/.local/share/mc/
	skins:          /home/jarek/.local/share/mc/skins/
	extfs.d:        /home/jarek/.local/share/mc/extfs.d/
	fish:           /home/jarek/.local/share/mc/fish/
	mcedit macros:  /home/jarek/.local/share/mc/mc.macros
	mcedit external macros: /home/jarek/.local/share/mc/mcedit/macros.d/macro.*
    Cache directory:  /home/jarek/.cache/mc/
jarek@trasownik:~/blachy$ mc --configure-options
 'PKG_CONFIG_PATH=/usr/local/lib64/pkgconfig:/usr/local/share/pkgconfig:/usr/lib64/pkgconfig:/usr/share/pkgconfig'

I've compiled this version, but also I used 4.8.16 form Slackware package and had same problem.

Change History

comment:1 Changed 3 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #3670.

comment:2 Changed 22 months ago by andrew_b

  • Description modified (diff)
Note: See TracTickets for help on using tickets.