Ticket #4048 (closed defect: duplicate)

Opened 7 months ago

Last modified 7 months ago

Error in BASH syntax highlighting

Reported by: cimbi Owned by:
Priority: major Milestone:
Component: mcedit Version: 4.8.23
Keywords: syntax highlighting Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

In some cases the BASH syntax highlighting gets broken. E. g. in this code snippet:

#!/bin/bash

path=$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )
echo "$path"

the nested command substitution (which is a correct bash construct) causes that next lines (starting with echo command) get incorrect syntax highlighting.

Please fix this case if possible.

Change History

comment:1 Changed 7 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate

Closed as duplicate of #2142.

Note: See TracTickets for help on using tickets.