Ticket #4003 (closed defect: duplicate)

Opened 12 days ago

Last modified 8 days ago

xselection paste on terminal broken

Reported by: metux Owned by:
Priority: major Milestone:
Component: mc-tty Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

When pasting into x terminal (middle click), the input gets broken like this:

0~foobar1~

The problem occours within subshell (ctrl+o), but not in the command line, and it remains when mc is closed (until terminal is closed).
It seems like mc is somehow confusing the termial.

Last known working version: 4.8.18 (debian)

Similar problem *occasionally* happend with older versions, but wasn't reproducable then. Now it's permanent.

Change History

comment:1 Changed 12 days ago by andrew_b

  • Milestone changed from 4.8.24 to Future Releases

Looks like duplicate of #3874

See also #3207, #3645, #3229.

comment:2 Changed 12 days ago by andrew_b

  • Component changed from mc-core to mc-tty

comment:3 Changed 8 days ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #3874.

Note: See TracTickets for help on using tickets.