Ticket #3969 (closed defect: duplicate)

Opened 2 months ago

Last modified 2 months ago

mcedit: incorrect syntax highlighting for .c and .cxx files

Reported by: pelya Owned by:
Priority: major Milestone:
Component: mcedit Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

I have found two bugs with highlighting preprocessor commands in .c files in mcedit:

#endif // preprocessor macro with one-line comment
int code; /* <-- this line is colorized incorrectly */
int code2; /* <-- next line is colorized properly */

/* this preprocessor macro is not colorized,
   when there is whitespace before '#'
   and the next line is not empty */

  #if not_colorized
int code3;

/* this preprocessor macro is colorized properly,
   the next line is empty */

  #if colorized

int code4;

Attachments

0001-mcedit-fixed-invalid-syntax-highlighting-when-both-c.patch (1.7 KB) - added by pelya 2 months ago.
Patch to fix issue 1
0002-mcedit-fixed-syntax-highlighting-bug-in-.c-and-.cxx-.patch (1.7 KB) - added by pelya 2 months ago.
Patch to fix issue 2

Change History

Changed 2 months ago by pelya

Patch to fix issue 1

Changed 2 months ago by pelya

Patch to fix issue 2

comment:1 Changed 2 months ago by pelya

Attached two patches to fix this bug

comment:2 Changed 2 months ago by andrew_b

Seems these patches fix #3487 too.

comment:3 Changed 2 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #3487.
I've copied description and attachments to #3487.
Thanks!

Note: See TracTickets for help on using tickets.