Ticket #3965 (closed enhancement: fixed)

Opened 7 months ago

Last modified 7 months ago

Fix include/editor order in mc.ext

Reported by: legends2k Owned by: andrew_b
Priority: major Milestone: 4.8.23
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

mc.ext has

` shell/i/.tex

Include=editor`

However, include/editor, where the Open action calls $EDITOR, is defined above this; hence .tex files aren't opened on Enter key press.

Moving include/editor below all Include=editor occurrences fixes this. I've given the patch for this too.

Additionally, I took the liberty to associate Markdown files in mc.ext.

Build Details
GNU Midnight Commander 4.8.22
Built with GLib 2.58.2
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, sftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

Attachments

mc.ext.patch (553 bytes) - added by legends2k 7 months ago.
Patch to fix include/editor order

Change History

Changed 7 months ago by legends2k

Patch to fix include/editor order

comment:1 Changed 7 months ago by andrew_b

Ticket #3964 has been marked as a duplicate of this ticket.

comment:2 Changed 7 months ago by andrew_b

  • Owner set to andrew_b
  • Status changed from new to accepted
  • Milestone changed from Future Releases to 4.8.23

comment:3 Changed 7 months ago by andrew_b

  • Branch state changed from no branch to on review

Thanks!

Branch: 3965_mc.ext_include
Initial changeset:6f562116cc69c86a1fad3c28b9e224b541920304.

comment:4 Changed 7 months ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset set to committed-master
  • Resolution set to fixed
  • Branch state changed from on review to merged

comment:5 Changed 7 months ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.