Ticket #3964 (closed enhancement: duplicate)

Opened 4 months ago

Last modified 4 months ago

Fix include/editor order in mc.ext

Reported by: legends2k Owned by:
Priority: major Milestone:
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

mc.ext has

` shell/i/.tex

Include=editor`

However, include/editor, where the Open action calls $EDITOR, is defined above this; hence .tex files aren't opened on Enter key press.

Moving include/editor below all Include=editor occurrences fixes this. I've given the patch for this too.

Additionally, I took the liberty to associate Markdown files in mc.ext.

Build Details
GNU Midnight Commander 4.8.22
Built with GLib 2.58.2
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, sftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

Change History

comment:1 Changed 4 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #3965 .

Note: See TracTickets for help on using tickets.