Ticket #3924 (closed enhancement: fixed)

Opened 3 months ago

Last modified 3 weeks ago

Do not populate Content field of "Find File" dialog with searches from viewer and editor

Reported by: Harkonnen Owned by: andrew_b
Priority: minor Milestone: 4.8.22
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

Or in another words do not automatically populate Content field from history unless last search in "Find File" dialog was with non-empty Content field.

This is an aftermath of #3594. While "Search for content" checkbox was here it was irrelevant that this filed was populated by last search in editor or viewer, but without it is extremely annoying. I constantly search for content when i dont intent to, even after a year of using a version without checkbox, so this is not a question of "getting used to it"

Personally i would have preferred to have "Search for content" checkbox back, but it was already denied in #3680, so not automatically populating Content field with searches from viewer and editor is a next best solution.

Change History

comment:1 Changed 3 months ago by andrew_b

The shared history is about 9 year old (#1460).
Apparently, wontfix.

comment:2 follow-up: ↓ 3 Changed 3 months ago by Harkonnen

I am not saying that history should not be shared, i am saying that Content field should not be automatically populated from shared history.

comment:3 in reply to: ↑ 2 Changed 3 months ago by andrew_b

We don't have search history other than shared one. So we populate the Content field from the history or do not populate it at all. You propose the second way.

comment:4 follow-up: ↓ 5 Changed 3 months ago by Harkonnen

Well, i am probably bad at explaining it (also english is not my native language).

The problem is not history. The problem is that Content field is not empty at opening of Find File dialog when last search from it was not for content.

Kind like i search for a file (by name). Then search in viewer/editor. Then open Find File and hit enter expecting it to search for the same name again. But instead search for a content, because content field was not empty. This really breaks usability. I have to constantly check if Content field is empty, even if i almost never search for content from file find dialog. It has become so annoying that i tried switching default editor/viewer just to avoid this problem. Unfortunately i like mcedit more than any other text editor i tried :(

"Search for content" checkbox was a best (IMHO) solution for this problem. Personally without it i would have preferred for Content field to be always empty on opening of a Find File dialog, but i understand that this is just me, and some people search for content from it more often than not, so this is not a good solution.

So i am asking for mc to remember if last search in Find File was with a non-empty content field, and only populate Content field if it was.

comment:5 in reply to: ↑ 4 Changed 4 weeks ago by andrew_b

  • Status changed from new to accepted
  • Owner set to andrew_b
  • Branch state changed from no branch to on review
  • Milestone changed from Future Releases to 4.8.22

Replying to Harkonnen:

So i am asking for mc to remember if last search in Find File was with a non-empty content field, and only populate Content field if it was.

Please test:

Branch: 3924_find_file_remember_empty_content
changeset:c57beb33c74ede7b9790421514ac597c6ecb965d

Last edited 4 weeks ago by andrew_b (previous) (diff)

comment:6 Changed 4 weeks ago by andrew_b

For the record: fix ticket number in the commit message.

comment:7 Changed 3 weeks ago by andrew_b

  • Votes for changeset set to andrew_b
  • Branch state changed from on review to approved

comment:8 Changed 3 weeks ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:9 Changed 3 weeks ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.