Ticket #3916 (closed defect: invalid)

Opened 7 months ago

Last modified 33 hours ago

File timestamps are not preserved when copying files from ZIP archives

Reported by: birdie Owned by:
Priority: major Milestone: 4.8.22
Component: mc-vfs Version: 4.8.19
Keywords: Cc: andrew_b
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Steps to reproduce:

  1. Download iview451.zip from https://www.irfanview.com/download_sites.htm (scroll to the bottom of the page)
  2. Try to extract files from this archive
  3. Timestamps will be lost

Change History

comment:1 follow-up: ↓ 2 Changed 7 months ago by zaytsev

  • Cc andrew_b added

Hi Andrew, this feels like yet another regression due to the nanosecond timestamp stuff... ? Birdie, do you know if this is a regression in master against 4.8.20 or not? Thank you.

comment:2 in reply to: ↑ 1 Changed 7 months ago by birdie

Replying to zaytsev:

Hi Andrew, this feels like yet another regression due to the nanosecond timestamp stuff... ? Birdie, do you know if this is a regression in master against 4.8.20 or not? Thank you.

No idea, haven't run a regression test. I'm running MC from Fedora 28 (4.8.19-something).

comment:3 Changed 7 months ago by zaytsev

  • Version changed from master to 4.8.19
  • Milestone changed from 4.8.21 to 4.8.22

Okay, then this should have been fixed in 4.8.20, moving this to next release, to test that it's gone and close if that's the case...

comment:4 Changed 6 months ago by zaytsev

  • Status changed from new to closed
  • Resolution set to invalid

In 4.8.21 timestamps are preserved, so closing.

comment:5 Changed 33 hours ago by mcoq

The opposite is open.
#3951

Note: See TracTickets for help on using tickets.