Ticket #3908 (closed defect: fixed)

Opened 8 months ago

Last modified 5 weeks ago

Quiet single file overwrite

Reported by: andrew_b Owned by: andrew_b
Priority: critical Milestone: 4.8.22
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

If target file exists, MC overwrites that file without confirmation.
The bug was introduced in #3149.

How to reproduce:

  1. Create two files: touch a aa.
  2. Stay on "aa".
  3. Make sure that Options/Confirmation?.../Overwrite option is checked on.
  4. Press Shift-F6
  5. Edit the "to:" value to "a" ("a" file exists) and press Enter.

Actual result:
The "a" file is overwritten w/o confirmation.

Expected result:
Since the "a" file exists the confirmation dialog must be shown.

Change History

comment:1 Changed 8 months ago by andrew_b

  • Status changed from new to accepted
  • Owner set to andrew_b
  • Branch state changed from no branch to on review
  • Milestone changed from Future Releases to 4.8.21

comment:2 Changed 8 months ago by andrew_b

  • Votes for changeset set to andrew_b
  • Branch state changed from on review to approved

comment:3 Changed 8 months ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:4 Changed 8 months ago by andrew_b

  • Status changed from testing to closed

comment:5 Changed 5 months ago by andrew_b

  • Status changed from closed to reopened
  • Votes for changeset committed-master deleted
  • Resolution fixed deleted
  • Branch state changed from merged to no branch

The bug has not been fixed completely.

Another test case:

  1. Create files:

mkdir -p test1/1 test2/1
echo "1" > test1/1/file
echo "2" > test2/1/file

  1. Run mc test1 test2
  2. Select directory "1" and press F6.

Result: "file" file is overwritten w/o confirmation.
Expected result: since the "file" file exists the confirmation dialog must be shown.

The bug was introduced in #3149.
Bad commit is [3ba4417c18b78cd18cbbe27b195df1a36dccf0b6].

Last edited 5 months ago by andrew_b (previous) (diff)

comment:6 Changed 5 months ago by andrew_b

  • Branch state changed from no branch to on review
  • Milestone changed from 4.8.21 to 4.8.22

comment:7 Changed 4 months ago by andrew_b

  • Votes for changeset set to andrew_b
  • Branch state changed from on review to approved

comment:8 Changed 4 months ago by andrew_b

  • Status changed from reopened to closed
  • Votes for changeset changed from andrew_b to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:9 Changed 5 weeks ago by JackM

  • Status changed from closed to reopened
  • Resolution fixed deleted

Since this regression is critical as it may result in data loss and the flaw is still present in the last release available 4.8.21 could you please introduce the fix in a form of a release as soon as possible?

comment:10 Changed 5 weeks ago by andrew_b

  • Status changed from reopened to closed
  • Resolution set to fixed

What reason for reopen? Bug is fixed, isn't it?
4.8.22 to be released in November.

comment:11 Changed 5 weeks ago by JackM

Apologies, yes, the regression is fixed with merged 5656ff5e8404b43bb808dcf2acfc0593e130b033.

However, I was merely suggesting that in case of such important issues there should be an emergency release taking place (out of regular release cycle), so that all the distros could pick it up.

Note: See TracTickets for help on using tickets.