Ticket #3894 (closed enhancement: duplicate)

Opened 19 months ago

Last modified 19 months ago

New markdown syntax highlighting doesn't play well with complex files.

Reported by: sknaumov Owned by:
Priority: major Milestone:
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Syntax highlighting from #3864 doesn't play well with lists or words containing underscores. And given that markdown files could contain not only ASCII text, it is better to be conservative in detecting contexts.
Otherwise syntax highlighting looks like a Christmas tree, but with toxic colors, forcing me to turn it off at all.
Proposed fix is attached.

Change History

comment:1 Changed 19 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone 4.8.21 deleted

Closed as duplicate of #3893.

Note: See TracTickets for help on using tickets.