Ticket #3879 (closed enhancement: fixed)

Opened 3 weeks ago

Last modified 12 days ago

i18n: argument type names in --help blocks

Reported by: dmartina Owned by: andrew_b
Priority: trivial Milestone: 4.8.21
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

Argument type names may be translated for some options that require them: <file>, <string> and <integer>. N_() macro needed, see included patch.

Attachments

helpargs.diff (2.0 KB) - added by dmartina 3 weeks ago.
Patch file for args.c

Change History

Changed 3 weeks ago by dmartina

Patch file for args.c

comment:1 Changed 2 weeks ago by andrew_b

Ticket #3878 has been marked as a duplicate of this ticket.

comment:2 Changed 2 weeks ago by andrew_b

Ticket #3877 has been marked as a duplicate of this ticket.

comment:3 Changed 2 weeks ago by zaytsev

Hi Andrew, if you want to commit directly, I approve :)

comment:4 Changed 2 weeks ago by andrew_b

Ok.

comment:5 Changed 12 days ago by andrew_b

  • Status changed from new to accepted
  • Owner set to andrew_b

comment:6 Changed 12 days ago by andrew_b

  • Votes for changeset set to zaytsev andrew_b
  • Branch state changed from no branch to approved

comment:7 Changed 12 days ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from zaytsev andrew_b to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:8 Changed 12 days ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.