Ticket #3815 (closed defect: fixed)

Opened 7 months ago

Last modified 7 months ago

Cannot return from QuickView panel

Reported by: andrew_b Owned by: mooffie
Priority: major Milestone: 4.8.20
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

How to reproduce.

  1. Set current (say, left) panel to file listing mode.
  2. Press C-x q (or use menu) to set other (right) panel to quick view mode.
  3. Press Tab to change panel.
  4. Now you are in the right (quick view) panel.
  5. Press Tab.

Result: nothing happens.
Expected result: switch back to left panel.

The bug was introduced in #3253.

Change History

comment:1 Changed 7 months ago by mooffie

  • Status changed from new to accepted
  • Owner set to mooffie

comment:2 Changed 7 months ago by mooffie

  • Blocking 3816 added

comment:3 Changed 7 months ago by mooffie

(This diagram explains the keyboard event workflow.)

comment:4 follow-up: ↓ 6 Changed 7 months ago by mooffie

  • Branch state changed from no branch to on review
  • Milestone changed from Future Releases to 4.8.20

branch: 3815_quickview_return
Initial changeset:f244f32e548b3eecb1ec566a36fd58740ce2ccc1


Notes:

  1. It turns out the 2nd commit wasn't necessary ("Factor out handle_cmdline_enter()") but I think it's nice to have anyway.
  1. The last commit makes TreeView, in addition to QuickView, mute the command-line. (Why? because it's a recipe for disaster to mix, for example, DEL for deleting a directory and BACKSPACE for deleting the previous char.)
  1. The bug prevented also other keys from functioning in QuickView (like C-u). (F10 still won't work, for unrelated reason, but that's handled in #3816.)

comment:5 Changed 7 months ago by mooffie

  • Blocking 3816 removed

comment:6 in reply to: ↑ 4 Changed 7 months ago by andrew_b

Replying to mooffie:

branch: 3815_quickview_return
Initial changeset:f244f32e548b3eecb1ec566a36fd58740ce2ccc1

Please don't forget to add reference to this ticket in the commit message before merge.

comment:7 Changed 7 months ago by andrew_b

  • Votes for changeset set to andrew_b
  • Branch state changed from on review to approved

comment:8 Changed 7 months ago by mooffie

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

Merged to master: [9df3933a4aabd3baeb5889d65cf895a10fb3e140]


Replying to andrew_b:

Please don't forget to add reference to this ticket in the commit message before merge.

Done.

comment:9 Changed 7 months ago by mooffie

  • Status changed from testing to closed

NEWS-4.8.20 updated.

Note: See TracTickets for help on using tickets.