Ticket #3787 (closed defect: fixed)

Opened 8 months ago

Last modified 8 months ago

extfs: tests for helpers using 'sort' may fail

Reported by: mooffie Owned by: mooffie
Priority: major Milestone: 4.8.20
Component: tests Version: master
Keywords: Cc:
Blocked By: Blocking: #3781
Branch state: merged Votes for changeset: committed-master

Description

The tests for urar and u7z may fail because the "expected output" files we provide were generated in the English locale. If the tester is run in some other locale (specifically C), the sort may be different than the one we provide.

Steps to reproduce the problem:

# this makes the urar/u7z tests fail!

$ LC_ALL=C make check

Change History

comment:1 Changed 8 months ago by mooffie

  • Owner set to mooffie
  • Status changed from new to accepted

Possible solution: make the tester set LC_COLLATE=C, or even LC_ALL=C. Any thoughts on this?

comment:2 Changed 8 months ago by mooffie

  • Blocking 3781 added

(In #3781) Replying to mooffie:

Ok, lets decide what to do:

  • This ticket could be renamed [...] Or we could start a new ticket by that name and make this one blocked by it [...] @Yury: what do you prefer?


Ok, I decided it for you: since we don't have @slyfox available for us 24/7, I started a new ticket for the 'sort' issue.

I'm making this ticket blocked by the two new tickets. When @slyfox tells us all is fixed we'll close it.

comment:3 Changed 8 months ago by mooffie

(comment:2 was copied by Trac from the blocked ticket. Don't be confused by it.)

comment:4 Changed 8 months ago by mooffie

  • Branch state changed from no branch to on review
  • Milestone changed from Future Releases to 4.8.20

branch: 3787_extfs_tester_sort_locale
changeset:4ad66ff272ef75c236587d860e8af00f42d9514c

comment:5 Changed 8 months ago by andrew_b

  • Votes for changeset set to andrew_b
  • Branch state changed from on review to approved

comment:6 Changed 8 months ago by zaytsev

  • Votes for changeset changed from andrew_b to andrew_b zaytsev

comment:7 Changed 8 months ago by ossi

  • Votes for changeset changed from andrew_b zaytsev to andrew_b zaytsev ossi

most common autotest bug (and fix) ever, i think. we repeatedly run into it in Qt as well - in a sufficiently complex system, you'll always have something locale-dependent.

comment:8 Changed 8 months ago by mooffie

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b zaytsev ossi to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:9 Changed 8 months ago by mooffie

  • Status changed from testing to closed

NEWS-4.8.20 updated.

Note: See TracTickets for help on using tickets.