Ticket #3757 (closed defect: fixed)

Opened 5 months ago

Last modified 5 months ago

Two column panel is broken in user defined listing mode

Reported by: zaytsev Owned by: mooffie
Priority: major Milestone: 4.8.19
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

https://bugzilla.redhat.com/show_bug.cgi?id=1383698

Using half2 or full2 is broken in user defined listing mode. There is only one column.

Version-Release number of selected component (if applicable):

mc-4.8.17-2

How reproducible:

Always

Steps to Reproduce:
1. Change listing mode for any panel to user defined.
2. Put half2 or full2 as a panel size.

Actual results:

There is only one column.

Expected results:

There should be two columns.

Verified on 4.8.18-164-g569569d.

Change History

comment:1 Changed 5 months ago by mooffie

  • Owner set to mooffie
  • Status changed from new to accepted
  • Branch state changed from no branch to on review

Branch: 3757_two_plus_columns_broken
changeset:05661eda1df0b7aaa258e386ce813f92d6d48188

(I'm not setting the "Milestone" field: I'll let you decide when you want this committed.)

comment:2 Changed 5 months ago by andrew_b

  • Votes for changeset set to andrew_b
  • Branch state changed from on review to approved
  • Milestone changed from Future Releases to 4.8.19

comment:3 follow-up: ↓ 5 Changed 5 months ago by zaytsev-work

I think it would be awesome if you could update the help file as well while you are at it. Currently it says:

After the panel size, you may specify the two columns mode on the panel, this is done by adding the number "2" to the user format string.

which is not really wrong, only it still does somehow imply that only 2 columns are supported.

comment:4 Changed 5 months ago by mooffie

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:5 in reply to: ↑ 3 Changed 5 months ago by mooffie

Replying to zaytsev-work:

I think it would be awesome if you could update the help file [...] it still does somehow imply that only 2 columns are supported.


Done.

(It was a bit challenging because, as the commit message explains, I wanted to avoid using the word "columns".)

comment:6 Changed 5 months ago by zaytsev-work

Awesome, thank you! Don't forget the NEWS page ;-)

comment:7 Changed 5 months ago by mooffie

  • Status changed from testing to closed

(Yes, NEWS was updated.)

Note: See TracTickets for help on using tickets.