Ticket #3680 (closed defect: wontfix)

Opened 3 years ago

Last modified 12 months ago

Restore the "Search for content" checkbox in the "Find File" dialog

Reported by: birdie Owned by:
Priority: major Milestone:
Component: mc-core Version: master
Keywords: Cc: egmont
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Here are several scenarios which are very tedious to complete without this removed checkbox:

  1. Sometimes you may want to alternate looking for and not looking for some content. The only solution is to delete the field and then restore it and in a process you'll have to hit quite a lot of keys, instead of clicking a single checkbox.
  1. I still haven't found a shortcut to empty the currently selected edit field in MC which means if you previously searched for a very long string of text, then you will have to spend a lot of time erasing it.

Please, restore this checkbox.

Change History

comment:1 Changed 3 years ago by birdie

  • Summary changed from Restore the "Search for content" checkbox to Restore the "Search for content" checkbox in the "Find File" dialog

comment:2 in reply to: ↑ description Changed 3 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to wontfix
  • Milestone 4.8.18 deleted

Replying to birdie:

  1. I still haven't found a shortcut to empty the currently selected edit field in MC
[input]
Remove = ctrl-w

comment:3 Changed 3 years ago by birdie

  • Status changed from closed to reopened
  • Resolution wontfix deleted

Still,

In the past:

Disable searching for content: click Alt + Shortcut (or alternatively one mouse click)
Reenable searching for content: click Alt + Shortcut (or alternatively one mouse click)

Now:
Disable searching for content: click Tab -> Click Ctrl + W (using mouse is not possible)
Reenable searching for content: Click Tab -> Click Down (using mouse is not possible)

comment:4 Changed 3 years ago by andrew_b

  • Status changed from reopened to closed
  • Resolution set to wontfix

comment:5 follow-up: ↓ 6 Changed 3 years ago by egmont

Note1: This was discussed and decided to be removed in ticket #3594.

Note2: There are several places in mc that can't be used by mouse. Apparently mc is not designed at all to be usable solely by mouse. E.g. there's ticket #3148 which no-one (including me) bothered to look at in 3.5+ years, so apparently just no-one cares enough. The F2 menu can't be closed by mouse either. If these are an issue at all, we'd need a full mouse usability audit to begin with. (Edit: ... and even then, being able to type or remove text by mouse couldn't be a requirement.)

Last edited 3 years ago by egmont (previous) (diff)

comment:6 in reply to: ↑ 5 ; follow-up: ↓ 8 Changed 3 years ago by andrew_b

Replying to egmont:

The F2 menu can't be closed by mouse either.

Actually, this is not true. User menu like any other dialog can be closed by click outside it. This is controlled by mouse_close_dialog option.

If you mean that "The F2 menu can't be closed by mouse because the Cancel button is absent", you're right.

comment:7 Changed 3 years ago by mooffie

@birdie: if this issue bothers you, you can use mc2. Here's a little snippet that adds a "Toggle conte&nt" button to that dialog. (Speaking of which, you may be interested in another snippet that fixes a usability issue there.)

(Or you could build a vi-style command to your liking. E.g., ":fc g_array" will open the find dialog and put "g_array" automatically in the content field.)

I still haven't found a shortcut to empty the currently selected edit field in MC


You can use alt-n. alt-n and alt-p are used to move in the history (after adding there the current text). Since you're at history's end, alt-n also clears the text.

comment:8 in reply to: ↑ 6 ; follow-up: ↓ 9 Changed 3 years ago by egmont

  • Cc egmont added

Replying to andrew_b:

User menu like any other dialog can be closed by click outside it.

At this moment I'm using 4.8.15 (the stock Ubuntu Xenial package), and clicking anywhere outside of that dialog is a no-op. (Maybe it was fixed since then, or maybe it's broken by an Ubuntu patch, I don't know.)

comment:9 in reply to: ↑ 8 Changed 3 years ago by andrew_b

Replying to egmont:

clicking anywhere outside of that dialog is a no-op. (Maybe it was fixed since then, or maybe it's broken by an Ubuntu patch, I don't know.)

As I wrote above:

This is controlled by mouse_close_dialog option

in ini file.

comment:10 Changed 3 years ago by egmont

Sorry, it's clear now.

comment:11 Changed 12 months ago by andrew_b

Ticket #3933 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.