Ticket #3669 (closed defect: fixed)

Opened 8 months ago

Last modified 7 months ago

bug in ftpfs with horizontal view

Reported by: foobarbaz Owned by: andrew_b
Priority: minor Milestone: 4.8.18
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

steps to reproduce:

  • start mc and leave the left panel selected
  • press META+, to change to horizontal view
  • press F9 to select menu
  • Select 'Below', then 'FTP link'
  • insert a valid FTP url and select 'OK'

now try to change directory in the 'upper' (usually left) panel.
you get: 'ftpfs: CWD failed.'

Change History

comment:1 Changed 8 months ago by andrew_b

  • Status changed from new to closed
  • Component changed from mc-core to mc-vfs
  • Resolution set to worksforme
  • Milestone Future Releases deleted

Works for me.

Use latest release 4.8.17.

comment:2 Changed 8 months ago by foobarbaz

  • Priority changed from major to minor
  • Status changed from closed to reopened
  • Resolution worksforme deleted

tried with 4.8.17, the bug is still there.

comment:3 Changed 8 months ago by andrew_b

  • Status changed from reopened to accepted
  • Owner set to andrew_b
  • Version changed from 4.8.16 to master
  • Branch state changed from no branch to on review
  • Milestone set to 4.8.18

Branch: 3669_load_passive_panel
changeset:5475e35378bfb577045c1b656e43cae45a24f8a9

Please test.

Actually, the deep refactoring of VFS directory content loading is required. Changing VFS in the passive panel ought to be performed with keep of VFS CWD.

comment:4 Changed 8 months ago by foobarbaz

yes, that patch fixes it.

comment:5 Changed 7 months ago by andrew_b

  • Votes for changeset set to foobarbaz andrew_b
  • Component changed from mc-vfs to mc-core
  • Branch state changed from on review to approved

comment:6 Changed 7 months ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from foobarbaz andrew_b to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:7 Changed 7 months ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.