Ticket #3631 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

shell link shows mangled utf-8 names

Reported by: yury_t Owned by:
Priority: major Milestone:
Component: mc-vfs Version: 4.8.16
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

In 4.8.16 shell link there's mangling of names coded in utf-8 from glyphs with codes higher than 0080h.

Every glyph from such name is expanded to groups of numbers, looking like octal representations of byte values, a bit like a ls output from utf-8 names with console misconfigured -- e.g., ls may show things like \200\217\204, and in shell link panel here it'd be like 200217204.

This seems to be new behaviour, I use shell link rarely, and I don't remember having such issues in 4.8.15.

Change History

comment:1 Changed 5 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #3611.

Note: See TracTickets for help on using tickets.