Ticket #3573 (closed defect: duplicate)

Opened 4 years ago

Last modified 2 months ago

copy does not honor setgid flag on target directory

Reported by: ntpt Owned by:
Priority: major Milestone:
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

I have a directory with setfacl and setgid flak on it so newly created stuff inside directory have a set group as parent directory

mkdir foo
chmod g+s foo

when I try to copy by midnight commander ie select in one panel and directory foo in second panel as destination, even with the PRESERVE ATTRIBUTES NOT checked, newly created directories under foo does not have a s bit set .

Hovewer, copying the same things with plain cp source/* /path/to/foo work and s bit of foo directory is preserved on copied subdirs

I consider it is a bug.

Reproducible: Always

Steps to Reproduce:
1.mkdir foo
2.chmod g+s foo

  1. in mc select some files and directories as source
  2. set preserve attributes as NOT checked and copy to foo

Actual Results:

ls -al
drwxrws--- foo
cd foo
ls -al
all copied directories
drwxrwx--- but not s

Expected Results:
newly created (ie copied) directories to foo/something to honour g+s of the parent directory, like plain cp does

version of mc = 4.8.15

I consider it major bug, because mc is used mainly for copying files so this function should be flawless

Change History

comment:1 Changed 2 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #3009.

Note: See TracTickets for help on using tickets.