Ticket #3202 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

recursive search not works on Windows Server NFS share

Reported by: kincza Owned by:
Priority: major Milestone: 4.8.13
Component: mc-core Version: 4.8.12
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:


GNU Midnight Commander 4.8.12
Built with GLib 2.24.2
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

Our NFS shares are provided by Windows 2012R2 NFS service now but the recursive search on shared directory is not working.

The client operating system: Debian squeeze
At first I tried the mc version packaged with the debian. Then I downloaded the newest version of mc from the midnight commander site. I compiled and tried it, but no solution.

The NFS share was mounted by the following parameter:

The directory is shared with ANSI encoding.

Change History

comment:1 Changed 8 years ago by andrew_b

Looks like #3097. Would you please test the patch attached to #3097?

comment:2 Changed 8 years ago by kincza

Ok, I recompiled with the patch and everything is ok.

comment:3 Changed 8 years ago by andrew_b

  • Blocked By 3097 added

(In #3097) Branch: 3097_smb_recursive_find

comment:4 Changed 8 years ago by andrew_b

  • Blocked By 3097 removed

comment:5 Changed 8 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone changed from Future Releases to 4.8.13
Note: See TracTickets for help on using tickets.