Ticket #3111 (closed enhancement: fixed)

Opened 4 years ago

Last modified 4 years ago

Make selection reset on CK_store configurable

Reported by: sknaumov Owned by: andrew_b
Priority: minor Milestone: 4.8.12
Component: mcedit Version: master
Keywords: selection Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

In mc-4.7.x.x selection was reset on CK_store (Copy to buffer on Ctrl+Ins). In mc-4.8.x it is not. I think, that this behavior should be configurable. From my point of view, there is no sense in keeping selection after copy, and resetting it makes me feel confident that operation completed successfully. Default behavior could be the same as in mc-4.8, but it would be good to be able to change it without patching and recompiling mc.

Attachments

mc-4.8.10-editor-drop-selection-on-CK_Store-configurable.patch (2.0 KB) - added by sknaumov 4 years ago.

Change History

comment:1 Changed 4 years ago by sknaumov

This ticket relates to #2660, which was marked as fixed, but original mc-4.7 behavior still can not be configured.

comment:2 follow-up: ↓ 4 Changed 4 years ago by sknaumov

Hope that this patch will be included in 4.8.11. I'm using non-configurable version of this patch for more than a year without any troubles.

comment:3 Changed 4 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #2660.

comment:4 in reply to: ↑ 2 Changed 4 years ago by andrew_b

Replying to sknaumov:

Hope that this patch will be included in 4.8.11.

We're going to release 4.8.11 at this week. This patch will be included in 4.8.12. Sorry.

comment:5 Changed 4 years ago by andrew_b

  • Status changed from closed to reopened
  • Resolution duplicate deleted
  • Milestone set to 4.8.12

#2660 is closed, so reopen this.

comment:6 Changed 4 years ago by andrew_b

  • Status changed from reopened to accepted
  • Owner set to andrew_b
  • Votes for changeset set to andrew_b
  • Branch state changed from no branch to on review

Branch: 3111_mcedit_reset_selection
changeset:7404393e131e8fda659e3374eeabc61bced5a588

comment:7 Changed 4 years ago by angel_il

  • Votes for changeset changed from andrew_b to andrew_b angel_il
  • Branch state changed from on review to approved

comment:8 Changed 4 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b angel_il to committed-master
  • Resolution set to fixed

comment:9 Changed 4 years ago by andrew_b

  • Status changed from testing to closed

comment:10 Changed 4 years ago by andrew_b

  • Branch state changed from approved to merged
Note: See TracTickets for help on using tickets.