Ticket #3071 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 months ago

[4.8.10]: FTBFS on GNU Hurd

Reported by: onlyjob Owned by:
Priority: major Milestone:
Component: mc-core Version: 4.8.10
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

MC-4.8.10 FTBFS on GNU Hurd, MC-4.8.8 was building fine.

filegui.c: In function 'statvfs_works':
filegui.c:293:1: error: invalid storage class for function 'filegui__check_attrs_on_fs'
 filegui__check_attrs_on_fs (const char *fs_path)
 ^
filegui.c:292:1: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement]
 static gboolean
 ^
filegui.c:345:1: error: invalid storage class for function 'file_frmt_time'
 file_frmt_time (char *buffer, double eta_secs)
 ^
filegui.c:357:1: error: invalid storage class for function 'file_eta_prepare_for_show'
 file_eta_prepare_for_show (char *buffer, double eta_secs, gboolean always_show)
 ^
filegui.c:374:1: error: invalid storage class for function 'file_bps_prepare_for_show'
 file_bps_prepare_for_show (char *buffer, long bps)
 ^
filegui.c:399:1: error: invalid storage class for function 'overwrite_query_dialog'
 overwrite_query_dialog (FileOpContext * ctx, enum OperationMode mode)
 ^
filegui.c:614:1: error: invalid storage class for function 'is_wildcarded'
 is_wildcarded (char *p)
 ^
filegui.c:629:1: error: invalid storage class for function 'place_progress_buttons'
 place_progress_buttons (WDialog * h, gboolean suspended)
 ^
filegui.c:647:1: error: invalid storage class for function 'progress_button_callback'
 progress_button_callback (WButton * button, int action)
 ^
filegui.c:661:1: warning: declaration of 'check_progress_buttons' shadows a global declaration [-Wshadow]
 check_progress_buttons (FileOpContext * ctx)
 ^
In file included from filegui.c:167:0:
filegui.h:30:20: warning: shadowed declaration is here [-Wshadow]
 FileProgressStatus check_progress_buttons (FileOpContext * ctx);
                    ^
filegui.c:713:1: warning: declaration of 'file_op_context_create_ui' shadows a global declaration [-Wshadow]
 file_op_context_create_ui (FileOpContext * ctx, gboolean with_eta,
 ^
In file included from filegui.c:167:0:
filegui.h:21:6: warning: shadowed declaration is here [-Wshadow]
 void file_op_context_create_ui (FileOpContext * ctx, gboolean with_eta,
      ^
filegui.c:858:1: warning: declaration of 'file_op_context_destroy_ui' shadows a global declaration [-Wshadow]
 file_op_context_destroy_ui (FileOpContext * ctx)
 ^
In file included from filegui.c:167:0:
filegui.h:23:6: warning: shadowed declaration is here [-Wshadow]
 void file_op_context_destroy_ui (FileOpContext * ctx);
      ^
filegui.c:877:1: warning: declaration of 'file_progress_show' shadows a global declaration [-Wshadow]
 file_progress_show (FileOpContext * ctx, off_t done, off_t total,
 ^
In file included from filegui.c:167:0:
filegui.h:32:6: warning: shadowed declaration is here [-Wshadow]
 void file_progress_show (FileOpContext * ctx, off_t done, off_t total,
      ^
filegui.c:924:1: warning: declaration of 'file_progress_show_count' shadows a global declaration [-Wshadow]
 file_progress_show_count (FileOpContext * ctx, size_t done, size_t total)
 ^
In file included from filegui.c:167:0:
filegui.h:34:6: warning: shadowed declaration is here [-Wshadow]
 void file_progress_show_count (FileOpContext * ctx, size_t done, size_t total);
      ^
filegui.c:943:1: warning: declaration of 'file_progress_show_total' shadows a global declaration [-Wshadow]
 file_progress_show_total (FileOpTotalContext * tctx, FileOpContext * ctx, uintmax_t copied_bytes,
 ^
In file included from filegui.c:167:0:
filegui.h:35:6: warning: shadowed declaration is here [-Wshadow]
 void file_progress_show_total (FileOpTotalContext * tctx, FileOpContext * ctx,
      ^
filegui.c:1017:1: warning: declaration of 'file_progress_show_source' shadows a global declaration [-Wshadow]
 file_progress_show_source (FileOpContext * ctx, const vfs_path_t * s_vpath)
 ^
In file included from filegui.c:167:0:
filegui.h:37:6: warning: shadowed declaration is here [-Wshadow]
 void file_progress_show_source (FileOpContext * ctx, const vfs_path_t * s_vpath);
      ^
filegui.c:1045:1: warning: declaration of 'file_progress_show_target' shadows a global declaration [-Wshadow]
 file_progress_show_target (FileOpContext * ctx, const vfs_path_t * s_vpath)
 ^
In file included from filegui.c:167:0:
filegui.h:38:6: warning: shadowed declaration is here [-Wshadow]
 void file_progress_show_target (FileOpContext * ctx, const vfs_path_t * path);
      ^
filegui.c:1070:1: warning: declaration of 'file_progress_show_deleting' shadows a global declaration [-Wshadow]
 file_progress_show_deleting (FileOpContext * ctx, const char *s, size_t * count)
 ^
In file included from filegui.c:167:0:
filegui.h:39:6: warning: shadowed declaration is here [-Wshadow]
 void file_progress_show_deleting (FileOpContext * ctx, const char *path, size_t * count);
      ^
filegui.c:1087:1: warning: declaration of 'file_progress_real_query_replace' shadows a global declaration [-Wshadow]
 file_progress_real_query_replace (FileOpContext * ctx,
 ^
In file included from filegui.c:165:0:
fileopctx.h:197:20: warning: shadowed declaration is here [-Wshadow]
 FileProgressStatus file_progress_real_query_replace (FileOpContext * ctx,
                    ^
filegui.c:1146:1: warning: declaration of 'file_mask_dialog' shadows a global declaration [-Wshadow]
 file_mask_dialog (FileOpContext * ctx, FileOperation operation,
 ^
In file included from filegui.c:167:0:
filegui.h:25:7: warning: shadowed declaration is here [-Wshadow]
 char *file_mask_dialog (FileOpContext * ctx, FileOperation operation,
       ^
filegui.c:1337:1: error: expected declaration or statement at end of input

Complete build log can be found here:

https://buildd.debian.org/status/fetch.php?pkg=mc&arch=hurd-i386&ver=3%3A4.8.10-1&stamp=1376382978

Change History

comment:1 Changed 4 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate

comment:2 Changed 4 years ago by andrew_b

Closed as duplicate of #3053.

comment:3 Changed 3 months ago by andrew_b

  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.