Ticket #3059 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Segfault while moving files

Reported by: ForeverYoung Owned by: andrew_b
Priority: blocker Milestone: 4.8.11
Component: mc-core Version: 4.8.10
Keywords: Cc: onlyjob@…, graham@…
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

If moving takes some time (didn't work with tmpfs).
If a dir with a file and a file out of that dir is tagged.

Steps to reproduce:

  1. There are /mnt/flashdisk/dir/bigfile, /mnt/flashdisk/anotherbigfile (100-200M each)
  2. On one panel - /mnt/flashdisk, on the opposite - /tmp
  3. Tag 'dir' and and 'anotherbigfile'
  4. F6 to /tmp
  5. After successful move of 'dir' with 'bigfile' - segfault (anotherbigfile is untouched)

Last lines of strace output is attached

Attachments

strace (1.1 KB) - added by ForeverYoung 4 years ago.
strace

Change History

Changed 4 years ago by ForeverYoung

strace

comment:1 Changed 4 years ago by andrew_b

  • Status changed from new to accepted
  • Owner set to andrew_b
  • Blocked By 2075 added
  • Milestone changed from Future Releases to 4.8.11

Fixed as part of #2075.

comment:2 Changed 4 years ago by a.panov

I think that this bug is critical for mc and the new version of mc (e.g. 4.8.10.1) with the fix should be released.

comment:3 Changed 4 years ago by a.panov

The changeset 1ae697368c933a5967416acdc7834102d6ac484d from https://www.midnight-commander.org/ticket/2075 for me does not fix segfaulting on moving. This bug was introduced in mc-4.8.10.

comment:4 Changed 4 years ago by onlyjob

  • Cc onlyjob@… added

comment:5 follow-up: ↓ 6 Changed 4 years ago by onlyjob

  • Priority changed from major to blocker

Although changeset from #2075 (mentioned in comment:3) fixed totals I've managed to reproduce crash with moving files. Raising severity...

Backtrace:

#0  gauge_show (g=0x0, shown=0) at gauge.c:175
#1  0x00007faf5f545433 in file_progress_show (ctx=ctx@entry=0x7faf6149ff50, done=done@entry=0, total=total@entry=0, stalled_msg=stalled_msg@entry=0x7faf5f5c554f "", 
    force_update=force_update@entry=0) at filegui.c:892
#2  0x00007faf5f54352d in panel_operate (source_panel=<optimized out>, operation=operation@entry=OP_MOVE, force_single=force_single@entry=0) at file.c:3040
#3  0x00007faf5f535d0f in rename_cmd () at cmd.c:900
#4  0x00007faf5f55c395 in midnight_execute_cmd (sender=0x7faf61483dd0, command=22) at midnight.c:1306
#5  0x00007faf5f533e9a in buttonbar_callback (w=0x7faf61483dd0, sender=<optimized out>, msg=<optimized out>, parm=<optimized out>, data=<optimized out>) at buttonbar.c:174
#6  0x00007faf5f53b514 in send_message (data=0x0, parm=1006, msg=MSG_HOTKEY, sender=0x0, w=<optimized out>) at ../../lib/widget/widget-common.h:162
#7  dlg_try_hotkey (d_key=1006, h=0x7faf61464400) at dialog.c:463
#8  dlg_key_event (d_key=1006, h=0x7faf61464400) at dialog.c:508
#9  dlg_process_event (h=h@entry=0x7faf61464400, key=1006, event=event@entry=0x7fffc011b220) at dialog.c:1221
#10 0x00007faf5f53b7ab in frontend_dlg_run (h=0x7faf61464400) at dialog.c:567
#11 dlg_run (h=0x7faf61464400) at dialog.c:1252
#12 0x00007faf5f55d84d in create_panels_and_run_mc () at midnight.c:959
#13 do_nc () at midnight.c:1774
#14 0x00007faf5f52b245 in main (argc=1, argv=0x7fffc011b4d8) at main.c:397

comment:6 in reply to: ↑ 5 Changed 4 years ago by andrew_b

Replying to onlyjob:

Although changeset from #2075 (mentioned in comment:3) fixed totals I've managed to reproduce crash with moving files. Raising severity...

Branch can contain many commits. If you want test some solution, you must use entire branch, not first commit in it.

Currently, the 2075_move_compute_total branch contains two commits. You must apply them both! After branch approving that two commits will be squashed and merged into master.

comment:7 Changed 4 years ago by ginggs

  • Cc graham@… added

comment:8 Changed 4 years ago by ForeverYoung

comment:9 Changed 4 years ago by onlyjob

Right, not all changesets were mentioned in #2075... :( Thanks for making me aware of that.

I tested MC-4.8.10 + changeset:1ae697368c933a5967416acdc7834102d6ac484d
and changeset:7871894760903e67af774ba572afeacda38b09f1 and I can't reproduce the problem any more.

Thank you. All good for merge as far as I'm concerned.

comment:10 Changed 4 years ago by a.panov

Indeed, the second patch fixes the bug.

comment:11 Changed 4 years ago by andrew_b

  • Blocked By 2075 removed

comment:12 Changed 4 years ago by andrew_b

  • Status changed from accepted to testing
  • Resolution set to fixed

comment:13 Changed 4 years ago by andrew_b

  • Status changed from testing to closed

comment:14 Changed 4 years ago by andrew_b

Ticket #3105 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.