Ticket #2925 (closed defect: worksforme)

Opened 9 years ago

Last modified 6 years ago

Built-in viewer does not work with text files in .ipk archives.

Reported by: dvlom Owned by:
Priority: major Milestone:
Component: mc-core Version: 4.8.1.3
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Step to reproduce:

  1. Press "Enter" on the .ipk file (OpenWRT package)
  2. Select any text file in list
  3. Press "F3" to view

You still have a window with the warning: "tar: This does not look like a tar archive" and "tar: Exiting with failure status due to previous error".

But built-in viewer displays a text file with no errors:
1) if rename foo.ipk file to foo.tar.gz
or
2) if on phase 3. press "Shift-F3" (instead "F3")

Attachments

dlengine_2.0-18_mipsel.ipk (15.0 KB) - added by angel_il 9 years ago.
test ipk package
luci-theme-base_0.11+svn9415-1_ar71xx.ipk (27.3 KB) - added by dvlom 9 years ago.
another test ipk file
test.ipk (5.0 KB) - added by dvlom 9 years ago.
test.tar.gz renamed to test.ipk

Change History

Changed 9 years ago by angel_il

test ipk package

comment:1 follow-up: ↓ 2 Changed 9 years ago by angel_il

i can't reproduce this.

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 9 years ago by dvlom

Hi.

Press "F3" on the file "debian-binary" produce an error.

Test system:
Live GNOME openSUSE 12.2, mc-4.8.1.3-4.1.2.rpm from openSUSE Current OSS repositry (out of the box).

comment:3 in reply to: ↑ 2 ; follow-up: ↓ 4 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Version changed from 4.8.6 to 4.8.1.3
  • Resolution set to worksforme

Replying to dvlom:

mc-4.8.1.3

Try latest release and feel free to reopen ticket if bug is still actual.

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 5 Changed 9 years ago by dvlom

Replying to andrew_b:

Try latest release and feel free to reopen ticket if bug is still actual.

Of course. On my working system openSUSE 12.2 (not live) - mc-4.8.6. Вehavior is similar to test system (Live GNOME openSUSE 12.2, mc-4.8.1.3).

Ubuntu 12.10 Live, mc-4.8.3 - another system in which the error is reproducible.

comment:5 in reply to: ↑ 4 Changed 9 years ago by angel_il

Replying to dvlom:

Replying to andrew_b:

Try latest release and feel free to reopen ticket if bug is still actual.

Of course. On my working system openSUSE 12.2 (not live) - mc-4.8.6. Вehavior is similar to test system (Live GNOME openSUSE 12.2, mc-4.8.1.3).

Ubuntu 12.10 Live, mc-4.8.3 - another system in which the error is reproducible.

please attach test ipk file ~10-100kb

Changed 9 years ago by dvlom

another test ipk file

comment:6 follow-up: ↓ 9 Changed 9 years ago by angel_il

mc 4.8.6
i can't reproduce on luci-theme-base_0.11+svn9415-1_ar71xx.ipk

comment:7 follow-up: ↓ 8 Changed 9 years ago by andrew_b

dvlom, compare your /etc/mc/mc.ext and ~/.config/mc/mc.ext in ipk-related part.

comment:8 in reply to: ↑ 7 Changed 9 years ago by dvlom

Replying to andrew_b:

dvlom, compare your /etc/mc/mc.ext and ~/.config/mc/mc.ext in ipk-related part.

File ~/.config/mc/mc.ext not exists.

Changed 9 years ago by dvlom

test.tar.gz renamed to test.ipk

comment:9 in reply to: ↑ 6 Changed 9 years ago by dvlom

Please test attached test.ipk. Enter into test.ipk file, then try to open any file with built-in viewer (press "F3"). I hope, that this time you will see an error ;)

I believe the program is trying to view all the files inside the .ipk-archive as .tar.gz-archives, and therefore there is a specified error ("tar: This does not look like a tar archive" and "tar: Exiting with failure status due to previous error").

comment:10 follow-up: ↓ 11 Changed 9 years ago by angel_il

no problem with test.ipk
in in panel "test.ipk/utar://test"

are you tried latest version?

comment:11 in reply to: ↑ 10 Changed 9 years ago by dvlom

Replying to angel_il:

no problem with test.ipk
in in panel "test.ipk/utar://test"

are you tried latest version?

Hi.
Yes, in panel "test.ipk/utar://test". mc version is 4.8.6 (and 4.8.1.3 on live openSUSE 12.2, and 4.8.3 on Ubintu 12.10 in VBox).
Are any options in the .spec file may solve the problem?
Or, is it may be the case in the operating system version?

comment:12 follow-ups: ↓ 13 ↓ 14 Changed 9 years ago by angel_il

$ LANG=C tar --version
tar (GNU tar) 1.26
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

please, show your tar version.

comment:13 in reply to: ↑ 12 Changed 9 years ago by dvlom

please, show your tar version.

The same version, 1.26

comment:14 in reply to: ↑ 12 ; follow-up: ↓ 15 Changed 9 years ago by andrew_b

Replying to angel_il:

$ LANG=C tar --version

mc doesn't use external tar.

comment:15 in reply to: ↑ 14 Changed 9 years ago by angel_il

Replying to andrew_b:

Replying to angel_il:

$ LANG=C tar --version

mc doesn't use external tar.

you right, but "tar: This does not look like a tar archive" and "tar: Exiting with failure status due to previous error" this 'tar' utility messages, not mc...

comment:16 follow-up: ↓ 17 Changed 9 years ago by dvlom

Hi!
I have just compiled a version based on nightly archive mc_4.8.6~git20121110.orig.tar.gz.
No errors, everything works :)

$ LANG=C mc -V
GNU Midnight Commander 4.8.6-94-g3bde17c
Built with GLib 2.32.4
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, fish, smbfs
Data types: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;

Guys, I'm sorry for your time. Thank you.

comment:17 in reply to: ↑ 16 Changed 9 years ago by angel_il

Replying to dvlom:

No errors, everything works :)

ok

comment:18 Changed 6 years ago by zaytsev

  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.