Ticket #2870 (closed defect: duplicate)

Opened 9 years ago

Last modified 9 years ago

invisible characters in command line after inserting from history

Reported by: RedRat Owned by:
Priority: major Milestone:
Component: mc-core Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

After updating to the latest version 4.8.1.4 inserting commands from history a slightly broken: all commands from history inserted to commandline as invisible characters, but after deleting one char or moving cursor all chars became visible again.

GNU Midnight Commander 4.8.1.4
Built with GLib 2.28.8
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

  1. Start Midnight Commander
  2. Try to load a command from a history: Esc+h, Enter
  3. See an empty spaces in the commandline
  4. Move a cursor by hitting Ctrl+b
  5. All chars in the commandline are became a visible

Change History

comment:1 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Version master deleted
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Duplicate of #2810. Please use search.

Note: See TracTickets for help on using tickets.