Ticket #2734 (closed defect: duplicate)

Opened 6 years ago

Last modified 2 months ago

Unable to establish remote connection if a previous one was terminated

Reported by: wimpog Owned by: slavazanko
Priority: major Milestone:
Component: mc-vfs Version: 4.8.0
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

When I connect to a remote server via the Shell link (/#sh:), stay connected for a while, and the connection is closed/terminated by the remote host, I cannot connect to any other remote server without restarting MC.

mc -V
GNU Midnight Commander 4.8.0
Built with GLib 2.28.8
Using the ncurses library
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

Change History

comment:1 Changed 6 years ago by slavazanko

update to latest version, please (4.8.1) and try again. Is error occurs?

comment:2 Changed 6 years ago by slavazanko

  • Owner set to slavazanko
  • Status changed from new to accepted

comment:3 Changed 2 years ago by andrew_b

  • Component changed from mc-core to mc-vfs
  • Milestone set to Future Releases

comment:4 Changed 2 months ago by andrew_b

  • Status changed from accepted to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #2256.

Note: See TracTickets for help on using tickets.