Ticket #2075 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

[4.7.1 regression] "Compute Totals" doesn't work for Move operation

Reported by: birdie Owned by: andrew_b
Priority: major Milestone: 4.8.11
Component: mc-core Version: master
Keywords: Cc: onlyjob@…
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

Since MC 4.7.1 "compute totals" option doesn't work for directories Move operation. All I see is a file copied after another file without any progress of an operation.

Change History

comment:1 Changed 7 years ago by angel_il

  • Milestone changed from 4.7.2 to 4.7

comment:2 Changed 7 years ago by birdie

  • Milestone changed from 4.7 to 4.7.3

comment:3 Changed 7 years ago by andrew_b

  • Milestone changed from 4.7.3 to 4.7

comment:4 Changed 6 years ago by birdie

  • Version changed from 4.7.1 to master
  • Milestone changed from 4.7 to 4.8

comment:5 Changed 4 years ago by andrew_b

  • Status changed from new to accepted
  • Owner set to andrew_b
  • Branch state set to on review
  • Milestone changed from 4.8 to 4.8.11

Branch: 2075_move_compute_total
changeset:1ae697368c933a5967416acdc7834102d6ac484d

comment:6 Changed 4 years ago by andrew_b

  • Blocking 3059 added

(In #3059) Fixed as part of #2075.

comment:7 Changed 4 years ago by slavazanko

  • Votes for changeset set to slavazanko

comment:8 Changed 4 years ago by onlyjob

  • Cc onlyjob@… added

comment:9 Changed 4 years ago by onlyjob

Sorry but #3059 is not fixed, I've just reproduced crash on moving files with changeset from comment:5 applied... Please find backtrace in #3059.

comment:10 Changed 4 years ago by onlyjob

Andrew pointed out that another changeset:7871894760903e67af774ba572afeacda38b09f1 has to be applied together with one from comment:6. I tested MC-4.8.10 plus both changesets applied and it appears that the problem is fixed. At least I can't reproduce the crash any more and "compute tolals" progress bar works.

IMHO all good for merge, thank you.

comment:11 Changed 4 years ago by angel_il

  • Votes for changeset changed from slavazanko to slavazanko angel_il
  • Branch state changed from on review to approved

comment:12 Changed 4 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from slavazanko angel_il to committed-master
  • Resolution set to fixed
  • Blocking 3059 removed
  • Branch state changed from approved to merged

comment:13 Changed 4 years ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.